AUTODESK VAULT
JOB SERVER

Introduction

What is the Job Server?

The Job Server is a feature used to off-load visualization file publishing (DWF) from the engineering
workstation during the check in process. Publishing visualization files of large assemblies can slow
the check in of designs. By off-loading this process, users can quickly check in files and ensure
consistent visualization file creation. The Job Server can also be used to synchronize properties
after a lifecycle change has been invoked on a file.

How It Works

Components

The Job Server consists of two components:

1.

Job Queue - A list, or queue, of jobs submitted by clients (Inventor, AutoCAD, Vault,
Autoloader) waiting to be processed. This queue is stored in and managed by the Vault
Server.

Job Processor - is a separate application that reserves queued jobs and pulls them from the
job server to process them. Since the job processor is installed along with the vault client, any
workstation with Autodesk Vault can be used to publish jobs.

Submitting a Job

Jobs are submitted to the job server when:

A user checks in a file which needs a visualization file created.

A user invokes an Update View command inside of the Vault client application.
Autoloader is used to load files into the vault and visualization files are needed.
A status change occurs on a file and an updated visualization file is needed.

A status change occurs on a file and properties need to be synchronized in the file.
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Job Server

Enabling the Job Server

The Job Server allows publishing jobs to be queued and processed at a later time. You must
activate the Job Server prior to sending any jobs to it for publishing.

Note: You must be an Administrator to enable the Job Server. Users logged in prior to the Job
Server being enabled must log in again to submit jobs.

1. Select Tools > Administration in the Vault client application.
2. In the Administration dialog, click the Visualization tab.

3. Select the Enable Job Server check box to activate the job server.
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Managing the Job Server Queue
The Job Server holds a list of jobs waiting to be processed.
1. Select Tools > Job Queue.
2. Inthe Job Server Queue dialog, you can sort the jobs by ID, Status, Description, Submitted
Date, or by whom they were submitted.

Note: The Job Server Queue dialog displays up to 1,000 jobs. A warning will appear if there
are more than 1,000 jobs in the queue.

Right-click on the column heading to customize the layout and view of the queue.

If you want to filter the list so that it only displays the jobs queued after a specific date and

time, click the Queued After list and specify a date.

3. Select a job that you want to modify and perform one of the following actions:

+ If you want to delete the job from the queue, click Remove.

» If the job has an error status, click Re-Submit to reprocess the job.

* If you want to remove the job processor from the task and leave the job in the queue, click
Reset to Queue.
Note: This command is not on the toolbar by default. To add the command, click the
toolbar list and select Add or Remove Buttons.

» If you want to assign the task to the job processor on your workstation, click Take
Ownership.
Note: This command is not on the toolbar by default. To add the command, click the
toolbar list and select Add or Remove Buttons.

4. Click Print to send the grid to the default printer. Click Refresh at anytime to update the
queue.

;:ansej Queued After: - J £3) -4 Re.submit L =] Remove | @| ] H
- 4 e = ,

D Status Description Submitted Date Submitted By
187 Pending DWF Create: 500-156.ipt 1/27/2009 10:41:15 PM Administrator
188 Pending DWF Create: 500-159.ipt 1/27/2009 10:41:15 PM Administrator
189 Pending DWF Create: 500-161.ipt 1/27/2009 10:41:16 PM Administrator
190 Pending DWF Create: 300-023.iam 1/27/2009 10:41:16 PM Administrator
191 Pending DWF Create: BS 3673-2 - 032MS ... |1/27/2009 10:41:16 PM Administrator
192 Pending DWF Create: 500-148.ipt 1/27/2009 10:41:16 PM Administrator

(3193 Pending DWF Create: 500-153.ipt 1/27/2009 10:41:17 PM Administrator
194 Pending DWF Create: 500-155.ipt 1/27/2009 10:41:17 PM Administrator
19 Pending DWF Create: 500-158.ipt 1/27/2009 10:41:17 PM Administrator
197 Pending DWF Create: 500-165.ipt 1/27/2009 10:41:17 PM Admini: -

Details
Job Type: Autodesk Vault.DWF.Create.ipt Description: DWF Create: 500-153.ipt
Submitted By: Administrator Status; Pending
Submitted Date:  1/27/2009 10:41:17 PM
Job Processor
192 Object(s) (1 selected)
—e
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Job Server Details

This table describes the details of the Job Server Queue dialog.

Detail

Description

Job Type

The type of job that was submitted for processing. Visualization jobs display
as Autodesk.Vault. DWF.Create {0} where {0} is the file extension.

Submitted By

Displays the name of the user who submitted the job to the queue.

Submitted Date

Displays the date and time the job was submitted to the queue.

Job Processor

Displays the name of the computer that has taken the job from the queue for
processing.

Displays more information about the job in the queue. This field will also

DL el display the DWF Create: filename.
Status Displays whether the job’s status is Pending, Processing, or Error.
Results Displays information only if the job has an error status.
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Job Server Commands

This table describes the commands on the Job Server Queue dialog.

Detail Description
Close Closes the Job Server Queue dialog.
Queued After F|Iter_s the list by showing the first 1,000 jobs queued after the specified date
and time.
Refresh Refreshes the queue.
: Reprocesses a job that has encountered an error. This button is only enabled
Re-Submit ; .
when a job has been placed in error state.
Removes the reservation of a job by the job processor.
Reset to
Queue Note: This command is not on the toolbar by default. To add the command,
click the toolbar list and select Add or Remove Buttons.
Transfers ownership of the job’s reservation to the current user’s job
processor.
When a site that has reserved jobs is deleted, or a back up is performed but
Transfer the information is restored to a different site, the pending jobs are deleted
Ownership from the queue. This feature allows administrators to claim ownership for
processing the job before it is deleted.
Note: This command is not on the toolbar by default. To add the command,
click the toolbar list and select Add or Remove Buttons
Print Prints the current queue grid to the default printer.
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Job Processor

From the Job Processor dialog, a user can pause and resume processing, set the vault user
account that is used to process jobs, and determine the types of jobs that the Job Processor
creates and publishes.

Access the application by selecting Start > All Programs > Autodesk > Autodesk Data
Management > Tools > Autodesk Job Processor for Vault [Edition].

Note: The Job Processor can be configured to launch automatically when the workstation is started
in the Job Processor’s Administration menu.

File  Administration Help
Job in Progress

Jobld: [45

Job Type: lAutodEsk,VaulLDWF.C reate.iam

Description: IDWF Create: harness.iam

Processing Start Time: l11'27/2009 10:42:52 PM

Processing... localhost @ Administrator

Job Processor Details

Detail Description

Job ID Displays the number of the job currently being processed.
Job Type Displays a description of the job being processed.
Description Displays more information about the job in the queue.
Status Displays the current state of the Job Processor.

Status Bar Displays the server name and the user account.
g:g:te.?iir;g Time at which the Job Processor began working on a job.
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Configuring the Job Processor

Logging into the Job Processor

The first time you access the job processor, you must specify the user name, password, and server
name. The job processor will remember these login credentials each time you log in until changed
through the Administration menu.

1.

o o~ w N

On the workstation where you want jobs to be processed, select Start > All Programs >
Autodesk > Autodesk Data Management Tools > Autodesk Job Processor for Vault
[Edition] to launch the Job Processor application.

Select Administration > Settings to display the Settings dialog.

Enter the Vault User Name and Password of the user for this workstation.

Specify the server from which you want the job processor to pull jobs for publishing.
Click OK to save your changes and close the Settings dialog.

Select File, Resume to log in to the specified server.
Note: Select File, Pause at any time to halt the job processor and prevent it from processing
any new jobs. If the job processor is in the middle of processing a job, it will finish the job first.

Configuring the Job Processor to start automatically

1.

On the workstation where you want jobs to be processed, select Start > All Programs >
Autodesk > Autodesk Data Management Tools > Autodesk Job Processor for Vault
[Edition] to launch the Job Processor application.

Select Administration > Start on Windows Logon. The Job Processor will launch whenever
the user logs into to Windows.
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Viewing job types
You can view the types of jobs that the Job Processor handles by accessing the Job Types dialog.

1. On the workstation where you want jobs to be processed, select Start > All Programs >
Autodesk > Autodesk Data Management > Tools > Autodesk Job Processor for Vault
[Edition] to launch the Job Processor application.

2. Select Administration > Job Types to display the Job Types dialog. If the workstation does
not have the necessary information to process a particular type of job, that type of file is
unchecked.

The ability for a Job Processor to handle a particular type of job is based on the application(s)
installed on the workstation to process the job.

Job Types

Type Required Application

DWEF creations of ipt, iam, idw, ipn Autodesk Inventor

DWEF creations of dwg DWG TrueView

Sync Properties of iam, ipt, idw, ipn  |None

Sync Properties of dwg None

Sync Properties of dot, doc, xls, xlt,

Microsoft Office
xla, ppt, pot, ppa, mpp, mpt, vsd, vst

Sync Properties of docx, dotx, xlIsx,
xltx, xlax, pptx, potx, ppax, mppx, None
mptx, vsdx, vstx

The job types a workstation can process are indicated by a check next to the type in the Job Types
dialog.

Job Types
The following job types are processed by this Job Processor,

[[] autodesk.vault.dwf.create.iam
[[] autodesk.vault.dwf.create.ipt

[7] autodesk.vault.dwf.create.ipn
[[] autodesk.vault.dwf.create.idw

autodesk.vault.dwf.create.dwg
autodesk.vault.syncproperties.iam
autodesk.vault.syncproperties.ipt
autodeskvault.syncproperties.ipn
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Managing Job Types

Managing the job types to be processed by a workstation is done by editing the Job Processor
configuration file JobProcessor.exe.config. This file is found in the <install dir>\Autodesk\Vault
[edition]\Explorer\ directory.

1. Open the file with Notepad.
2. Find the jobHandlers section.

3. Comment out the line that contains the handler you do not want the workstation to process.
Use <!-- handler --> to comment out the line.

4. Save the file and restart the Job Processor. Check the Job Types dialog to verify that the job
type no longer appears.

Managing Check Period

By default, the Job Processor checks the server for a new job every 10 minutes. This time can be
adjusted by editing the JobProcessor.exe.config file.

1. Open the file with Notepad.
2. Find the appSettings section.

3. Edit the line that has <add key="PeriodInMinutes value="10" /> to the desired time. (minimum
value of 1)

4. Save the file and restart the Job Processor.

. | JobProcessor.exe.con g - Notepad™

File  Edit  Format  Wiew Help

<appSettings>
<add key="PeriodInMinutes" value="10" />
<l-- WebService timeout {in milliseconds)--=
<add key="WebServiceTimeout" value="1000000" />
<|-- 1000 secs = 1000000 milli --=
</appsSettings>
<microsoft, web, services3>
<messaging >
<maxMessagelength value="51200"> </maxMessagelLength>
<mtom clientMode="0n" />
</messaging=
| <security>
<!-- Specifies the time buffer used by WSE to determine when a 504F message is valid.
set to the max of 24hr in seconds -->
<timeTolerancelnSeconds value="86400" />
<fsecurity>
</microsoft. web. services3>
| </configuration>
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Job Processor Logs

The Job Processor logs all jobs in the Event Viewer Application log on the workstation. This log can

be useful when troubleshooting failed or incomplete jobs.

B! Event Viewer

File  &Action  Yiew Help

«= | #EHEBE

@ Ewent Yiewer (Local)
> _L# Custorm Wiews
F] _L Windows Logs
Application
Security
] Setup
System
El Forwarded Even
i [ &pplications and Se
> _g Saved Logs
;’j Subscriptions

Application

Lesvel Date and Tirme Source
@Information 20.03.2009 17:06:13 MESOLEAUTODESKY. .
@Information 20.03.2009 17:26:15 MESOLEAUTODESKY. .
®Information 29.03.2009 17:38:16 MESOLEAUTODESKY. .
@Information 28.03.2009 17:55:49 Autodesk Job Process..,
@Information 29,03.2009 17:55:50 Autodesk Job Process..,
@Information 29.03,2009 17:55:50 Autodesk Job Process..,
mT £ £ 2002 n0n 17,.ce,01 L, o e i

Multi-site Support

The Job Server will support multi-site environments by logging into a specific server and only
processing jobs that are associated with that server. In the illustration below, any job processor that
logs into Site B will only process jobs that are at Site B. The same happens for Job Processors in

Site A.

Buwent 0, Autodesk Jlob Processor

General | Details

Job Processors

Infarmation 29.03.2009 17:53:30
Job 55 Autodesk Maulk. SyncProperties.idw : Campleted executing

10

Job 1 - Site A
Job 2 - Site A
Job 3 - Site B
Job 4 - Site B

Job Processors
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Job Processor Licensing

The Job Processor consumes one Vault server license during the time it connects to the server
to reserve a job. The Job Processor is not continuously logged into the Vault server during the
processing of a job and the Vault server license it acquired is released.

If a Job being processed requires Inventor, an Inventor license is consumed while it is processing
the job and released when the job has completed.

Scheduling the Job Processor

Use the Windows Task Scheduler to configure when and how often the Job processor starts. You
must be logged in with a Windows user account to schedule this task.

Open the Windows Task Scheduler.

Configure the frequency and time to start the Job Processor.

Ao N o~

Save the task.

Note: Be sure to configure the account setting prior to the scheduled task starting the first time.
This only needs to be set once and the Job Processor will use this account each time it runs.

The Job Processor can also be started when a user logs into Windows. This is done by selecting
“Start on Windows Log in” in the Administration menu of the Job Processor dialog.

11

Browse to the JobProcessor.exe in the <install dir>\Autodesk\Vault [edition|\Explorer\ directory.
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Submitting a Job

Jobs can be submitted to the Job Server for processing during the check in process, during the
change of lifecycle state, when loading files with Autoloader or while performing an Update View in
the client application.

In the Check-in dialog, select the Settings button and select Send to Job Server in the Visualization
Attachment Option section.

[ £ | Settings =)
Relationships
[¥] Indude children

[ indude parents
Direct parents anly
Visualization Attachment Options
() Create during chedk-in
(@) Send to Job Server

*) Do not create

| @ o ][ concel ]

To synchronize properties in a lifecycle state transition, check the box next to Synchronize
properties and update view using Job Server in the Transition dialog.

"y

¥ Transition "
From State: T Skake:

| Bump primary revision (1]
|[4]] Symchronize properties and updsts view using Job Server v

12
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To use the Job Server in the client application:

1. Select a file and then select the arrow next to the Update button.

2. In the menu that appears, select Queue Update.
3. Select the Update button.

Note: This setting will remain constant and every time you select the Update button, the Job

Server will be used to create the visualization file.

ik cowsmiot 2 Admanestrator SI2712008 251 PH | Fixed refersnces for move fokder
o (F VR Mt 2 Adventagtor | SEETIE000 51 PR Frood roharsnons for soren fokder
il ¥ Arbor Frame.gt 3 Adinisirator | SI27/2008 251 PH Foeed referances For morn Fokder
[B | ol th |HANOLE Cap g 2 Aderatids gl SIETI2008 251 PH | Fread rahorafions for mevn Fokder
(N e s S1Z7]2000 251 PH | Fresdi e Y ———
2 ek | ThBLE PLATE gt z SIET{2008 251 PM | Fined rfersnces for moe foider
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(3 & -
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EEEEE |
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To use the Job Server with multiple files at once, select all files in the grid, then select Actions >

Update View > Queue Update.

_[ ..- *ate... J[q ill‘

Checked In
3 Admiristrator _WMEISPH
2] e Mastar [ | GROOVE FIN.Bt 3 Advetrator|6/2412008 10:M4... |
= (1) Yok Explorer (§) [ GIB PLATE. ipt 2 Administrator 5/27/2008 2:51 PM | Ficed references for move folder
0 I Contort Corder Fles C I 2 5/2712006 2:51 PH | Foced references for mave fokder
2 572742008 2:51 PM | Foced references for move fokder

5/27/2008 2:51 P | Feced references for move folder

story | Uses | whers used | Vow |

File Name:  THUM SCREW. bt

o) Comoe )8 2

2 J[8hORAR @ |Er@- O-&

(=2
My Shortads: Past - THUMB SCREW

11 Fles (5 selected) locahost Vauk g Admistrator |

[+~] update Locally
- Queue Update
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To use the Job Server in the Autoloader, select Create Visualization Attachment then select Using
the Job Server radio button.

EE Autoloader
Specify Data Subsets
The checkboxes below provide you with clean subsets for upload. AutOdESk'
| Daka Fiters; 4l Dista | |
Name Lize the drop down kst bo sedect what yvou would
2 | B to upload or lsave the setting on “All Data”
STy | to upload all vabd data,
EHA iy Designs
[EH¥] iy Boted Connextion [+] Creats Visualization Attachment
[#] ik basic_plate.ipt
IE[ I%'Bnhd__cmmn.m O Immeciatety
Bl spnde ot {5) Using the Job Server
@ <tack | [ Upbad | [ Concel
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Update DWF View in the Web client

The web client can also be used to update a visualization file. Use the Update visualization
file feature to re-publish visualization files that are currently out-of-date. The visualization file is
published by the job server, so no additional utilities are required by the web client.

A7 i | e R TenT 0 I b - I (i) el ol I e i el B | e il

gﬂ s s et PR vt 850 T Bt TS e = B =TD A ¥ | 41 £
W P 00T - el Propesties =0 R ek T
Autodesk’ [Fog] [Topout]
Vault Autodesk’
Fies | [PESET pvanced seach
&) Back to File Search Aesults for *300-010°
Canaral ok v
Dasd Flle: 300-010.idw - General Properties uesdate visuabzation fie
Hmtory / 7
Whert Used Category Mame: Marwlactuing P4
Attschmants 7 I
Filla Naaee: A00-030 kv 7 I
Roirwiibon: 1 / I
7
State: Ralgfind I
7
Crated .'f"/ Pascal l
Charcked In
it Print view

Update visualization file

NOTE: The Update visualization file command is only available if the job server is enabled.
1. Click Update visualization file.

2. Log into the vault. The visualization file update request is sent to the job server.
The job server confirms the request and adds the job to the queue.

2 muhorization - Mcrorolt inferned Cxplorer prosided by 1T Serd.,. = x

Please authorize to execute a job for updating the
visualization file,

USar rams:

Password:
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Example Workflow

Jobs can be submitted to the Job Server for processing during the check in process, during the
change of lifecycle state, while loading files with Autoloader or while performing an Update View in
the client application.

In the Check-in dialog, select the Settings button and select Send to Job Server in the Visualization
Attachment Option section.

{7 Jdob1-SteaA
B Job2-Siea

Job Server\
@ Job Queue Reserve a Job

- (Y
M

Check-in
visualization file

Vault Client Job Processor Visualization i
Check-in isualization files
created.
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